Java Output Formatting - Hacker Rank Solution

Java Output Formatting - Hacker Rank Solution
Java Output Formatting - Hacker Rank Solution


Problem


Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.
To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.



Input Format :-

Every line of input will contain a String followed by an integer.
Each String will have a maximum of 10 alphabetic characters, and each integer will be in the inclusive range from 0 to 999.

Output Format :-

In each line of output there should be two columns:
The first column contains the String and is left justified using exactly 15 characters.
The second column contains the integer, expressed in exactly 3 digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.



Sample Input :

java 100
cpp 65
python 50

Sample Output :

================================
java           100 
cpp            065 
python         050 
================================

Explanation :

Each String is left-justified with trailing whitespace through the first 15 characters. The leading digit of the integer is the16th character, and each integer that was less than 3 digits now has leading zeroes.



Solution :-


 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);

            System.out.println("================================");
            for(int i=0;i<3;i++){
                String s1=sc.next();
                int x=sc.nextInt();
                System.out.printf("%-15s", s1);
                System.out.printf("%03d%n", x );
            }
            System.out.println("================================");

    }
}


Next Post Previous Post
2 Comments
  • Anonymous
    Anonymous Thursday, April 28, 2022

    Can someone explain the code line by line, I've been trying to figure out what each line does? Having the solution is nice but it's useless if you can't understand it and internalize it.

    • Anonymous
      Anonymous Wednesday, July 27, 2022

      Well I'm so confused. this makes no senus at all...you guys are fucked up

Add Comment
comment url