Deque-STL in C++ - Hacker Rank Solution


Deque-STL in C++ - Hacker Rank Solution



Problem


Double ended queue or Deque(part of C++ STL) are sequence containers with dynamic sizes that can be expanded or contracted on both ends (either its front or its back). The member functions of deque that are mainly used are:

Deque Template:
std::deque<value_type>

Declaration:
deque<int> mydeque; //Creates a double ended queue of deque of int type

Size :

int length = mydeque.size(); //Gives the size of the deque

Push:

mydeque.push_back(1); //Pushes element at the end
mydeque.push_front(2); //Pushes element at the beginning

Pop:

mydeque.pop_back(); //Pops element from the end
mydeque.pop_front(); //Pops element from the beginning

Empty:

mydeque.empty() //Returns a boolean value which tells whether the deque is empty or not

To know more about deque, click here

Given a set of arrays of size N and an integer K, you have to find the maximum integer for each and every contiguous subarray of size K for each of the given arrays.



Input Format :

First line of input will contain the number of test cases T. For each test case, you will be given the size of array N and the size of subarray to be used K. This will be followed by the elements of the array Ai.

Constraints :

  • 1 <= N <= 1000
  • 1 <= T <= 10000
  • 1 <= K <= N
  • 1 <= Ai <= 10000, where Ai, is the is the ith element in the Array A;

Output Format :

For each of the contiguous subarrays of size K of each array, you have to print the maximum integer.



Sample Input :

2
5 2
3 4 6 3 4
7 4
3 4 5 8 1 4 10

Sample Output :

4 6 6 4
8 8 8 10

Explanation :

For the first case, the contiguous subarrays of size 2 are {3,4},{4,6},{6,3} and {3,4}. The 4 maximum elements of subarray of size 2 are: 4 6 6 4.

For the second case,the contiguous subarrays of size 4 are {3,4,5,8},{4,5,8,1},{5,8,1,4} and {8,1,4,10}. The 4 maximum element of subarray of size 4 are: 8 8 8 10.



Solution :


 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
//Deque-STL in C++ - Hacker Rank Solution
#include <iostream>
#include <deque> 
using namespace std;

void printKMax(int arr[], int n, int k)
{
	//Write your code here.
	/* Deque-STL in C++ - Hacker Rank Solution START */
    deque<int> Qi(k);
    int i;
    for (i = 0; i < k; i++) 
    {
        while ((!Qi.empty()) && (arr[i] >= arr[Qi.back()]))
            Qi.pop_back();
        Qi.push_back(i);
    }
    for ( ; i < n; i++) {
        cout << arr[Qi.front()] << " ";
        while ((!Qi.empty()) && (Qi.front() <= i - k))
            Qi.pop_front();
        while ((!Qi.empty()) && (arr[i] >= arr[Qi.back()]))
            Qi.pop_back();
        Qi.push_back(i);
    }
    cout << arr[Qi.front()] << endl;
    /* Deque-STL in C++ - Hacker Rank Solution END */
}

int main()
{
  
	int t;
	cin >> t;
	while(t>0) 
	{
		int n,k;
    	cin >> n >> k;
    	int i;
    	int arr[n];
    	for(i=0;i<n;i++)
      		cin >> arr[i];
    	printKMax(arr, n, k);
    	t--;
  	}
  	return 0;
}


Next Post Previous Post
No Comment
Add Comment
comment url